Installing NX 9 – Changes and Prerequisites

Installing NX 9 – Changes and Prerequisites

Earlier this month, NX 9 was released. It is available for download at https://download.industrysoftware.automation.siemens.com/download.php. You will need your WebKey and password to access the Siemens FTP site.
 

Prerequisites:
 
1. You will need at least SPLM License Server version 6.1.1. This version is provided in the download/media of the NX 9 installation.
The download of the NX 9 installation would be the zip file from Siemens FTP site. Media would be the installation DVD. You can also download the latest version of SPLM License Server, version 6.3.0 from the Siemens ftp site at the link: https://download.industrysoftware.automation.siemens.com/siemens_plm_licensing/Installs/
 

2. The SPLM License server install requires that Java 1.5+ is installed on the system.
 

3. NX 9 License file. You can verify the version of the license file by editing the license file in notepad or an editor. The header will contain “version: 9”
 

 


 

4. 64 bit Operating System.
 

Minimum Certified Operating Systems
 


 

Windows XP and Vista
 
Windows XP support from Microsoft is ending and Vista was rarely deployed so these two versions of Windows are not supported by
NX 9. Siemens PLM Software has not performed testing on these versions and cannot resolve any issues related to NX 9 running on these operating systems. If NX 9 is deployed on these versions of Windows, any issues will have to be replicated on Windows 7 before filing an incident report.
 

Changes involving the client (where the NX product is installed) machine’s environment variables.
 
With the NX 9.0 version you are able to run all versions from NX 5.0 to NX 9.0. For clients with NX 8.5 down to NX 5.0 you will still use the old environment variable.
 
UGS_LICENSE_SERVER= 28000@<HostName>
 


 

Starting with NX 9, there is a new environment variable used on the client to point to the license server.
 

SPLM_LICENSE_SERVER= 28000@<HostName>
 

 

As stated earlier, older versions will run by using the old environment variable (UGS_LICENSE_SERVER) and NX 9 and versions moving
forward will use the new variable (SPLM_LICENSE_SERVER).  Both of these environment variables can exist on one client if you are running multiple versions.
 

Brandon Carter
Applications Engineer
Ally PLM Solutions Inc
 



«

»
No Comments

Post a Comment